#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+)(?<!10)(?<!127)\.(\d+)(?<!192\.168)(?<!172\.(1[6-9]|2[0-9]|3[0-1]))\.(\d+)\.(\d+)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"No match" & @CRLF & _
"172.16.1.1" & @CRLF & _
"172.16.0.0" & @CRLF & _
"172.16.0.0" & @CRLF & _
"172.31.0.1" & @CRLF & _
"172.20.22.22" & @CRLF & _
"10.255.255.255" & @CRLF & _
"192.168.1.1" & @CRLF & _
"192.168.12.34" & @CRLF & _
"192.168.111.222" & @CRLF & _
"127.255.255.255" & @CRLF & _
"127.0.4.4" & @CRLF & _
"127.0.0.1" & @CRLF & _
"127.255.255.255" & @CRLF & _
"127.123.123.123" & @CRLF & _
"127.1.1.1" & @CRLF & _
"127.12.23.56" & @CRLF & _
"" & @CRLF & _
"Match" & @CRLF & _
"172.15.2.2" & @CRLF & _
"172.33.33.33" & @CRLF & _
"192.167.1.1" & @CRLF & _
"192.169.1.1" & @CRLF & _
"207.168.207.11" & @CRLF & _
"207.168.207.22" & @CRLF & _
"192.2.199.199" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")