package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^[a-zA-Z-'/, ]{0,25}$|^_$`)
var str = `ab-abc
-
hello
abc-'/ citizen
john citizen
abcdefghijklmnopqrstuvwxy
abcdefghijklmnopqrstuvwxy
abc&
_
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}