using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z-'/, ]{0,25}$|^_$";
string input = @"ab-abc
-
hello
abc-'/ citizen
john citizen
abcdefghijklmnopqrstuvwxy
abcdefghijklmnopqrstuvwxy
abc&
_
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}