#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^[a-zA-Z-'/, ]{0,25}$|^_$"
Local $sString = "ab-abc" & @CRLF & _
"-" & @CRLF & _
"hello " & @CRLF & _
"abc-'/ citizen" & @CRLF & _
"john citizen" & @CRLF & _
"abcdefghijklmnopqrstuvwxy" & @CRLF & _
"abcdefghijklmnopqrstuvwxy" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"abc&" & @CRLF & _
"_" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")