$re = '/<\s*?script\s*?([^>]*)\s*?>\s*?(.+)?\s*?<\s*?\/script\s*?>/Us';
$str = '< script type="text/javascript" src="//vk.com/js/api/openapi.js?65"> < /script >
<script type="text/javascript" >
VK.init({apiId: 3251711, onlyWidgets: true});
</script>
<script type="text/javascript" src="http://keddr.com/wp-content/themes/keddr3-1/js/lite-youtube.js" ></script>
<script type="text/javascript" src="http://keddr.com/wp-content/themes/keddr3-1/js/jquery.complexify.js" > sfdbb </script>
<script type="text/javascript" >
$(function () {
if (($("#pass1").length 0)) {
$("#pass1").complexify({}, function (valid, complexity) {
if (complexity < 1) {
$(\'#progress\').css({\'width\': complexity + \'%\'}).removeClass(\'progressbarValidGood\').addClass(\'progressbarInvalid\');
$(\'.passAlert\').hide();
} else if (complexity > 1 && complexity < 40) {
$(\'#progress\').css({\'width\': complexity + \'%\'}).removeClass(\'progressbarValidGood\').addClass(\'progressbarInvalid\');
$(\'.passAlert.good\').hide();
$(\'.passAlert.bad\').fadeIn();
} else if (complexity > 40) {
$(\'#progress\').css({\'width\': complexity + \'%\'}).removeClass(\'progressbarValidGood\').addClass(\'progressbarValid\');
$(\'.passAlert.good\').hide();
$(\'.passAlert.strong\').fadeIn();
}
$(\'#complexity\').html(Math.round(complexity) + \'%\');
});
}
});
</script >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);