import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*?script\\s*?([^>]*)\\s*?>\\s*?(.+)?\\s*?<\\s*?\\/script\\s*?>";
final String string = "< script type=\"text/javascript\" src=\"//vk.com/js/api/openapi.js?65\"> < /script >\n\n"
+ "<script type=\"text/javascript\" >\n"
+ " VK.init({apiId: 3251711, onlyWidgets: true});\n"
+ "</script>\n\n"
+ "<script type=\"text/javascript\" src=\"http://keddr.com/wp-content/themes/keddr3-1/js/lite-youtube.js\" ></script>\n\n"
+ "<script type=\"text/javascript\" src=\"http://keddr.com/wp-content/themes/keddr3-1/js/jquery.complexify.js\" > sfdbb </script>\n\n"
+ "<script type=\"text/javascript\" >\n"
+ " $(function () {\n"
+ " if (($(\"#pass1\").length 0)) {\n"
+ " $(\"#pass1\").complexify({}, function (valid, complexity) {\n"
+ " if (complexity < 1) {\n"
+ " $('#progress').css({'width': complexity + '%'}).removeClass('progressbarValidGood').addClass('progressbarInvalid');\n"
+ " $('.passAlert').hide();\n"
+ " } else if (complexity > 1 && complexity < 40) {\n"
+ " $('#progress').css({'width': complexity + '%'}).removeClass('progressbarValidGood').addClass('progressbarInvalid');\n"
+ " $('.passAlert.good').hide();\n"
+ " $('.passAlert.bad').fadeIn();\n"
+ " } else if (complexity > 40) {\n"
+ " $('#progress').css({'width': complexity + '%'}).removeClass('progressbarValidGood').addClass('progressbarValid');\n"
+ " $('.passAlert.good').hide();\n"
+ " $('.passAlert.strong').fadeIn();\n"
+ " }\n"
+ " $('#complexity').html(Math.round(complexity) + '%');\n"
+ " });\n"
+ " }\n"
+ " }); \n"
+ " \n"
+ "</script >";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}