#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?Us)<\s*?script\s*?([^>]*)\s*?>\s*?(.+)?\s*?<\s*?\/script\s*?>"
Local $sString = "< script type="text/javascript" src="//vk.com/js/api/openapi.js?65"> < /script >" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript" >" & @CRLF & _
" VK.init({apiId: 3251711, onlyWidgets: true});" & @CRLF & _
"</script>" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript" src="http://keddr.com/wp-content/themes/keddr3-1/js/lite-youtube.js" ></script>" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript" src="http://keddr.com/wp-content/themes/keddr3-1/js/jquery.complexify.js" > sfdbb </script>" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript" >" & @CRLF & _
" $(function () {" & @CRLF & _
" if (($("#pass1").length 0)) {" & @CRLF & _
" $("#pass1").complexify({}, function (valid, complexity) {" & @CRLF & _
" if (complexity < 1) {" & @CRLF & _
" $('#progress').css({'width': complexity + '%'}).removeClass('progressbarValidGood').addClass('progressbarInvalid');" & @CRLF & _
" $('.passAlert').hide();" & @CRLF & _
" } else if (complexity > 1 && complexity < 40) {" & @CRLF & _
" $('#progress').css({'width': complexity + '%'}).removeClass('progressbarValidGood').addClass('progressbarInvalid');" & @CRLF & _
" $('.passAlert.good').hide();" & @CRLF & _
" $('.passAlert.bad').fadeIn();" & @CRLF & _
" } else if (complexity > 40) {" & @CRLF & _
" $('#progress').css({'width': complexity + '%'}).removeClass('progressbarValidGood').addClass('progressbarValid');" & @CRLF & _
" $('.passAlert.good').hide();" & @CRLF & _
" $('.passAlert.strong').fadeIn();" & @CRLF & _
" }" & @CRLF & _
" $('#complexity').html(Math.round(complexity) + '%');" & @CRLF & _
" });" & @CRLF & _
" }" & @CRLF & _
" }); " & @CRLF & _
" " & @CRLF & _
"</script >"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")