$re = '/(\b\d+(?:[\.\,]\d+)*(?:da|[yzafpnμmcdhkMGgTPEZY])?(?:hz|[mgrlvw])?\b)/';
$str = '2khz
2hz
30.89mw
30.89mm
100,98da
200da
100hz
90hz
90Mv
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);