const regex = /(\b\d+(?:[\.\,]\d+)*(?:da|[yzafpnμmcdhkMGgTPEZY])?(?:hz|[mgrlvw])?\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\d+(?:[\\.\\,]\\d+)*(?:da|[yzafpnμmcdhkMGgTPEZY])?(?:hz|[mgrlvw])?\\b)', 'g')
const str = `2khz
2hz
30.89mw
30.89mm
100,98da
200da
100hz
90hz
90Mv
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}