use strict;
my $str = '2khz
2hz
30.89mw
30.89mm
100,98da
200da
100hz
90hz
90Mv
';
my $regex = qr/(\b\d+(?:[\.\,]\d+)*(?:da|[yzafpnμmcdhkMGgTPEZY])?(?:hz|[mgrlvw])?\b)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}