$re = '/^\d{0,6}(\.\d{1,2})?$/m';
$str = '123456.12
21231
123456
15465.43
23.34
6.45
12345678
123456.331';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;