package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{0,6}(\.\d{1,2})?$`)
var str = `123456.12
21231
123456
15465.43
23.34
6.45
12345678
123456.331`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}