import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{0,6}(\\.\\d{1,2})?$";
final String string = "123456.12\n"
+ "21231\n"
+ "123456\n"
+ "15465.43\n"
+ "23.34\n"
+ "6.45\n"
+ "12345678\n"
+ "123456.331";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}