import Foundation
let pattern = #"Score[^\.]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Pale straw in colour, it has that characteristic lychee and rose petal nose and Turkish delight flavour, finishing elegantly dry on a pear-like note. Score - 4 Stars. (Tony Aspler, tonyaspler.com, Feb. 2016)
The quick red fox jumped over the lazy brown dog
Score.+?\.
.*?quick[^z]*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)