$re = '/Score[^\.]*/';
$str = 'Pale straw in colour, it has that characteristic lychee and rose petal nose and Turkish delight flavour, finishing elegantly dry on a pear-like note. Score - 4 Stars. (Tony Aspler, tonyaspler.com, Feb. 2016)
The quick red fox jumped over the lazy brown dog
Score.+?\\.
.*?quick[^z]*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);