package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Score[^\.]*`)
var str = `Pale straw in colour, it has that characteristic lychee and rose petal nose and Turkish delight flavour, finishing elegantly dry on a pear-like note. Score - 4 Stars. (Tony Aspler, tonyaspler.com, Feb. 2016)
The quick red fox jumped over the lazy brown dog
Score.+?\.
.*?quick[^z]*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}