package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[\s]*@testable[\s]*import[\s]*\w`)
var str = `@testable import Chase
@testable import JPM
@testable
import
Chase
@testable
import
JPM
@testable import Chase
@testable import JPM
@testable
import
Chase
@testable
import
Chase
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}