using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\s]*@testable[\s]*import[\s]*\w";
string input = @"@testable import Chase
@testable import JPM
@testable
import
Chase
@testable
import
JPM
@testable import Chase
@testable import JPM
@testable
import
Chase
@testable
import
Chase
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}