re = /(?:\W|^)(paragrafo(?:s?)|par[s.]?\.?)\s*(\d+)/m
str = 'paragrafo6o
par123
par 89
par.21
pars.344
exempar234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end