$re = '/(?:\W|^)(paragrafo(?:s?)|par[s.]?\.?)\s*(\d+)/m';
$str = 'paragrafo6o
par123
par 89
par.21
pars.344
exempar234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);