import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\W|^)(paragrafo(?:s?)|par[s.]?\\.?)\\s*(\\d+)";
final String string = "paragrafo6o\n"
+ "par123\n"
+ "par 89\n"
+ "par.21\n"
+ "pars.344\n"
+ "exempar234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}