use strict;
my $str = 'Should Match:
5.6.20.4-dev+a2c4ok ok
1.3.2
12.0.2.1000 ok
3.60.2.300 ok
0.0.2.1-dev ok
2.0.3.1dev ok
this is v1.2.3.1 ok
1.2.3
30.0000.1.222.3333
Should Not Match
1
1.
12
12.
123
123.';
my $regex = qr/(?<Semantic>(?<Major>[0-9]+)\.(?<Minor>[0-9]+)(?:\.(?=[0-9]))?(?<Maintenance>[0-9]+)?(?:\.(?=[0-9]))?(?<Patch>[0-9]+)?)(?<Label>(?:(?:\.|\-|\+)?\w+)+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}