const regex = /(?<Semantic>(?<Major>[0-9]+)\.(?<Minor>[0-9]+)(?:\.(?=[0-9]))?(?<Maintenance>[0-9]+)?(?:\.(?=[0-9]))?(?<Patch>[0-9]+)?)(?<Label>(?:(?:\.|\-|\+)?\w+)+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<Semantic>(?<Major>[0-9]+)\\.(?<Minor>[0-9]+)(?:\\.(?=[0-9]))?(?<Maintenance>[0-9]+)?(?:\\.(?=[0-9]))?(?<Patch>[0-9]+)?)(?<Label>(?:(?:\\.|\\-|\\+)?\\w+)+)?', 'gm')
const str = `Should Match:
5.6.20.4-dev+a2c4ok ok
1.3.2
12.0.2.1000 ok
3.60.2.300 ok
0.0.2.1-dev ok
2.0.3.1dev ok
this is v1.2.3.1 ok
1.2.3
30.0000.1.222.3333
Should Not Match
1
1.
12
12.
123
123.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}