// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[Dd][Uu]-{0,1}[Ee]\s*:{0,1}\s*\d{2}BR\d{9}-{0,1}\d{1}").unwrap();
let string = "DUe23BR0000409942";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}