$re = '/[Dd][Uu]-{0,1}[Ee]\s*:{0,1}\s*\d{2}BR\d{9}-{0,1}\d{1}/m';
$str = 'DUe23BR0000409942';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);