const regex = /[Dd][Uu]-{0,1}[Ee]\s*:{0,1}\s*\d{2}BR\d{9}-{0,1}\d{1}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[Dd][Uu]-{0,1}[Ee]\\s*:{0,1}\\s*\\d{2}BR\\d{9}-{0,1}\\d{1}', 'gm')
const str = `DUe23BR0000409942`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}