re = /,(?=\S)/
str = '1234567,01/15/23,01/15/23,Debit Card,-135.0,,SUPER BLAND, DDS,Health & Fitness,DR,1234.56'
# Print the match result
str.match(re) do |match|
puts match.to_s
end