using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=\S)";
string input = @"1234567,01/15/23,01/15/23,Debit Card,-135.0,,SUPER BLAND, DDS,Health & Fitness,DR,1234.56";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}