#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ",(?=\S)"
Local $sString = "1234567,01/15/23,01/15/23,Debit Card,-135.0,,SUPER BLAND, DDS,Health & Fitness,DR,1234.56"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")