# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^[A-Z]).*\n[A-Za-z 1-9]*\s(\d)*\s"
test_str = ("Frontken Corporation Berhad (651020-T) 85 \n"
"ANNUAL REPORT 2018 \n"
" \n"
"Notes To The Financial Statements \n"
"(cont’d) \n"
" \n"
" \n"
"9. EARNINGS PER SHARE \n"
" \n"
"Basic earnings per share is calculated by dividing profit after taxation attributable to owners of the Company by the weighted \n"
"average number of ordinary shares in issue during the financial year. \n"
" \n"
" The Group \n"
"2018 2017 \n"
"Profit after taxation attributable to owners of the Company (RM) 52,256,898 29,857,681 \n"
"Number of shares in issue as of 1 January 1,053,435,130 1,053,435,130 \n"
"Effects of: \n"
"Treasury shares acquired (5,466,600) (5,466,600 ) \n"
"Weighted average number of ordinary shares for basic earnings \n"
"per share computation as of 31 December 1,047,968,530 1,047,968,530 \n"
" \n"
" \n"
"Basic earnings per ordinary share attributable \n"
"to equity holders of the Company (sen) 4.99 2.85 \n"
"The Group has not issued any dilutive potential ordinary shares and hence, the diluted earnings per share is equal to the basic \n"
"earnings per share. \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.