import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[A-Z]).*\\n[A-Za-z 1-9]*\\s(\\d)*\\s";
final String string = "Frontken Corporation Berhad (651020-T) 85 \n"
+ "ANNUAL REPORT 2018 \n"
+ " \n"
+ "Notes To The Financial Statements \n"
+ "(cont’d) \n"
+ " \n"
+ " \n"
+ "9. EARNINGS PER SHARE \n"
+ " \n"
+ "Basic earnings per share is calculated by dividing profit after taxation attributable to owners of the Company by the weighted \n"
+ "average number of ordinary shares in issue during the financial year. \n"
+ " \n"
+ " The Group \n"
+ "2018 2017 \n"
+ "Profit after taxation attributable to owners of the Company (RM) 52,256,898 29,857,681 \n"
+ "Number of shares in issue as of 1 January 1,053,435,130 1,053,435,130 \n"
+ "Effects of: \n"
+ "Treasury shares acquired (5,466,600) (5,466,600 ) \n"
+ "Weighted average number of ordinary shares for basic earnings \n"
+ "per share computation as of 31 December 1,047,968,530 1,047,968,530 \n"
+ " \n"
+ " \n"
+ "Basic earnings per ordinary share attributable \n"
+ "to equity holders of the Company (sen) 4.99 2.85 \n"
+ "The Group has not issued any dilutive potential ordinary shares and hence, the diluted earnings per share is equal to the basic \n"
+ "earnings per share. \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}