#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[A-Z]).*\n[A-Za-z 1-9]*\s(\d)*\s"
Local $sString = "Frontken Corporation Berhad (651020-T) 85 " & @CRLF & _
"ANNUAL REPORT 2018 " & @CRLF & _
" " & @CRLF & _
"Notes To The Financial Statements " & @CRLF & _
"(cont’d) " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"9. EARNINGS PER SHARE " & @CRLF & _
" " & @CRLF & _
"Basic earnings per share is calculated by dividing profit after taxation attributable to owners of the Company by the weighted " & @CRLF & _
"average number of ordinary shares in issue during the financial year. " & @CRLF & _
" " & @CRLF & _
" The Group " & @CRLF & _
"2018 2017 " & @CRLF & _
"Profit after taxation attributable to owners of the Company (RM) 52,256,898 29,857,681 " & @CRLF & _
"Number of shares in issue as of 1 January 1,053,435,130 1,053,435,130 " & @CRLF & _
"Effects of: " & @CRLF & _
"Treasury shares acquired (5,466,600) (5,466,600 ) " & @CRLF & _
"Weighted average number of ordinary shares for basic earnings " & @CRLF & _
"per share computation as of 31 December 1,047,968,530 1,047,968,530 " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Basic earnings per ordinary share attributable " & @CRLF & _
"to equity holders of the Company (sen) 4.99 2.85 " & @CRLF & _
"The Group has not issued any dilutive potential ordinary shares and hence, the diluted earnings per share is equal to the basic " & @CRLF & _
"earnings per share. " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")