# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((case) (.*):)([.\s]*)((return) (.*);)"
test_str = (" switch (frequency)\n"
" {\n"
" case GIIncomeFrequencyEnum.ANNUALLY:\n"
" return QuotingPeriodType.Yearly;\n"
" case GIIncomeFrequencyEnum.QUARTERLY:\n"
" return QuotingPeriodType.Quarterly;\n"
" case GIIncomeFrequencyEnum.MONTHLY:\n"
" return QuotingPeriodType.Monthly;\n"
" case GIIncomeFrequencyEnum.BI_WEEKLY:\n"
" return QuotingPeriodType.Every2Weeks;\n"
" case GIIncomeFrequencyEnum.WEEKLY:\n"
" return QuotingPeriodType.Weekly;\n"
" case GIIncomeFrequencyEnum.DAILY:\n"
" return QuotingPeriodType.Daily;\n"
" case GIIncomeFrequencyEnum.HOURLY:\n"
" return QuotingPeriodType.Hourly;\n"
" case GIIncomeFrequencyEnum.ONE_TIME:\n"
" return QuotingPeriodType.OneTime;\n"
" case GIIncomeFrequencyEnum.SEMI_MONTHLY:\n"
" return QuotingPeriodType.SemiMonthly;\n"
" default:\n"
" return QuotingPeriodType.Yearly;\n"
" }")
subst = "$2 $7:$4$6 $3;"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.