import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((case) (.*):)([.\\s]*)((return) (.*);)";
final String string = " switch (frequency)\n"
+ " {\n"
+ " case GIIncomeFrequencyEnum.ANNUALLY:\n"
+ " return QuotingPeriodType.Yearly;\n"
+ " case GIIncomeFrequencyEnum.QUARTERLY:\n"
+ " return QuotingPeriodType.Quarterly;\n"
+ " case GIIncomeFrequencyEnum.MONTHLY:\n"
+ " return QuotingPeriodType.Monthly;\n"
+ " case GIIncomeFrequencyEnum.BI_WEEKLY:\n"
+ " return QuotingPeriodType.Every2Weeks;\n"
+ " case GIIncomeFrequencyEnum.WEEKLY:\n"
+ " return QuotingPeriodType.Weekly;\n"
+ " case GIIncomeFrequencyEnum.DAILY:\n"
+ " return QuotingPeriodType.Daily;\n"
+ " case GIIncomeFrequencyEnum.HOURLY:\n"
+ " return QuotingPeriodType.Hourly;\n"
+ " case GIIncomeFrequencyEnum.ONE_TIME:\n"
+ " return QuotingPeriodType.OneTime;\n"
+ " case GIIncomeFrequencyEnum.SEMI_MONTHLY:\n"
+ " return QuotingPeriodType.SemiMonthly;\n"
+ " default:\n"
+ " return QuotingPeriodType.Yearly;\n"
+ " }";
final String subst = "$2 $7:$4$6 $3;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}