$re = '/((case) (.*):)([.\s]*)((return) (.*);)/m';
$str = ' switch (frequency)
{
case GIIncomeFrequencyEnum.ANNUALLY:
return QuotingPeriodType.Yearly;
case GIIncomeFrequencyEnum.QUARTERLY:
return QuotingPeriodType.Quarterly;
case GIIncomeFrequencyEnum.MONTHLY:
return QuotingPeriodType.Monthly;
case GIIncomeFrequencyEnum.BI_WEEKLY:
return QuotingPeriodType.Every2Weeks;
case GIIncomeFrequencyEnum.WEEKLY:
return QuotingPeriodType.Weekly;
case GIIncomeFrequencyEnum.DAILY:
return QuotingPeriodType.Daily;
case GIIncomeFrequencyEnum.HOURLY:
return QuotingPeriodType.Hourly;
case GIIncomeFrequencyEnum.ONE_TIME:
return QuotingPeriodType.OneTime;
case GIIncomeFrequencyEnum.SEMI_MONTHLY:
return QuotingPeriodType.SemiMonthly;
default:
return QuotingPeriodType.Yearly;
}';
$subst = "$2 $7:$4$6 $3;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;