# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:-|(?P<real_ip>[\-\da-f.:]+))\s+\[(?P<remote_ip>[\da-f.:]+)\]\s+[\w\.\-]+\s+(?<remote_user>\S+)\s+\[(?<timestamp>[^\]]+)\]\s+\"(?:\-|(?<request>\w+) (?<request_uri>[^ \?]+)(?:\?(?<request_uri_query>[^ ]*))? (?<request_version>[\w\/\.]+))\"\s+(?P<status>[1-9]\d{2})\s+(?P<body_bytes_sent>\d+)\s+\"(?<http_referer>[^\"]+)\"\s+\"(?<http_user_agent>[^\"]+)\"\s+\[(?:\-|(?P<upstream_response_time>\d+(?:.\d+)?))\s+(?P<request_time>\d+(?:.\d+)?)\]"
test_str = ("0.0.0.0 [192.168.255.53] - - [11/Aug/2020:06:25:22 +0000] \"GET /monitoring/health/ HTTP/1.1\" 200 0 \"-\" \"-\" [0.000 0.005]\n\n"
"- [192.168.255.53] - - [11/Aug/2020:06:25:22 +0000] \"GET /monitoring/health/ HTTP/1.1\" 200 0 \"-\" \"-\" [0.000 0.005]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.