$re = '/(?:-|(?P<real_ip>[\-\da-f.:]+))\s+\[(?P<remote_ip>[\da-f.:]+)\]\s+[\w\.\-]+\s+(?<remote_user>\S+)\s+\[(?<timestamp>[^\]]+)\]\s+"(?:\-|(?<request>\w+) (?<request_uri>[^ \?]+)(?:\?(?<request_uri_query>[^ ]*))? (?<request_version>[\w\/\.]+))"\s+(?P<status>[1-9]\d{2})\s+(?P<body_bytes_sent>\d+)\s+"(?<http_referer>[^"]+)"\s+"(?<http_user_agent>[^"]+)"\s+\[(?:\-|(?P<upstream_response_time>\d+(?:.\d+)?))\s+(?P<request_time>\d+(?:.\d+)?)\]/m';
$str = '0.0.0.0 [192.168.255.53] - - [11/Aug/2020:06:25:22 +0000] "GET /monitoring/health/ HTTP/1.1" 200 0 "-" "-" [0.000 0.005]
- [192.168.255.53] - - [11/Aug/2020:06:25:22 +0000] "GET /monitoring/health/ HTTP/1.1" 200 0 "-" "-" [0.000 0.005]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);