import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:-|(?P<real_ip>[\\-\\da-f.:]+))\\s+\\[(?P<remote_ip>[\\da-f.:]+)\\]\\s+[\\w\\.\\-]+\\s+(?<remote_user>\\S+)\\s+\\[(?<timestamp>[^\\]]+)\\]\\s+\"(?:\\-|(?<request>\\w+) (?<request_uri>[^ \\?]+)(?:\\?(?<request_uri_query>[^ ]*))? (?<request_version>[\\w\\/\\.]+))\"\\s+(?P<status>[1-9]\\d{2})\\s+(?P<body_bytes_sent>\\d+)\\s+\"(?<http_referer>[^\"]+)\"\\s+\"(?<http_user_agent>[^\"]+)\"\\s+\\[(?:\\-|(?P<upstream_response_time>\\d+(?:.\\d+)?))\\s+(?P<request_time>\\d+(?:.\\d+)?)\\]";
final String string = "0.0.0.0 [192.168.255.53] - - [11/Aug/2020:06:25:22 +0000] \"GET /monitoring/health/ HTTP/1.1\" 200 0 \"-\" \"-\" [0.000 0.005]\n\n"
+ "- [192.168.255.53] - - [11/Aug/2020:06:25:22 +0000] \"GET /monitoring/health/ HTTP/1.1\" 200 0 \"-\" \"-\" [0.000 0.005]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}