# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)((?>globalis|transnat|facili|container|LIC|trad|TNC).+?)\s+(.*?)"
test_str = ("- Freedom of trade\n"
" - The World Trade Organisation (WTO) is allowing free trade between all countries.\n"
" - This causes globalisation because allowing freedom of trade means anyone can trade with anyone and get better access to ores & minerals. \n"
"---\n"
"- Containerisation\n"
" - Containerisation is when products are put in big boxes to be transported all around the world.\n"
" - It causes globalisation because it made it easy & cheap transport things overseas.\n"
" - Lots of things were modified to fit the new containers and make it the industry standard.\n"
"---\n"
"- Locating outside of home countries\n"
" - Companies (e.g. IKEA) are building market, outside of where they were originally located\n"
" - Locating in foreign countries can allow companies to take advantage of local suppliers and local materials.\n"
" - IKEA was founded in Sweden but now sells in 38 countries like Iceland, Kuwait and Malaysia.\n"
"---\n"
"- Improvements of communications\n"
" - The internet and mobile phones give people more access to communication outside of their country.\n"
"---\n"
"- Cheap Labour\n"
" - In countries like India, China and Brazil, labour costs are much lower.")
subst = "$1 ==$2== $3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.