import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)((?>globalis|transnat|facili|container|LIC|trad|TNC).+?)\\s+(.*?)";
final String string = "- Freedom of trade\n"
+ " - The World Trade Organisation (WTO) is allowing free trade between all countries.\n"
+ " - This causes globalisation because allowing freedom of trade means anyone can trade with anyone and get better access to ores & minerals. \n"
+ "---\n"
+ "- Containerisation\n"
+ " - Containerisation is when products are put in big boxes to be transported all around the world.\n"
+ " - It causes globalisation because it made it easy & cheap transport things overseas.\n"
+ " - Lots of things were modified to fit the new containers and make it the industry standard.\n"
+ "---\n"
+ "- Locating outside of home countries\n"
+ " - Companies (e.g. IKEA) are building market, outside of where they were originally located\n"
+ " - Locating in foreign countries can allow companies to take advantage of local suppliers and local materials.\n"
+ " - IKEA was founded in Sweden but now sells in 38 countries like Iceland, Kuwait and Malaysia.\n"
+ "---\n"
+ "- Improvements of communications\n"
+ " - The internet and mobile phones give people more access to communication outside of their country.\n"
+ "---\n"
+ "- Cheap Labour\n"
+ " - In countries like India, China and Brazil, labour costs are much lower.";
final String subst = "$1 ==$2== $3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}