re = /(?:(?:<\/?\w+>)+|[^<>]+)/
str = '<b>Jeremi Stadler</b> at Auddly publishing has created song <i>Darkness</i> for you.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end