package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:<\/?\w+>)+|[^<>]+)`)
var str = `<b>Jeremi Stadler</b> at Auddly publishing has created song <i>Darkness</i> for you.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}