$re = '/(?:(?:<\/?\w+>)+|[^<>]+)/';
$str = '<b>Jeremi Stadler</b> at Auddly publishing has created song <i>Darkness</i> for you.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);