re = /\s*([a-z]{2})(?:-[A-Z]{2})?(?:\s*;q=([0-9]\.[0-9]))?(?:\s*,|$)/i
str = 'cs-CZ,en-US;q=0.8,sk-SK;q=0.6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end