const regex = /\s*([a-z]{2})(?:-[A-Z]{2})?(?:\s*;q=([0-9]\.[0-9]))?(?:\s*,|$)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*([a-z]{2})(?:-[A-Z]{2})?(?:\\s*;q=([0-9]\\.[0-9]))?(?:\\s*,|$)', 'gi')
const str = `cs-CZ,en-US;q=0.8,sk-SK;q=0.6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}