import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*([a-z]{2})(?:-[A-Z]{2})?(?:\\s*;q=([0-9]\\.[0-9]))?(?:\\s*,|$)";
final String string = "cs-CZ,en-US;q=0.8,sk-SK;q=0.6";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}