# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?=\b\d{3}\b)0?1?2?3?4?5?6?7?8?9?(?<=\d{3}))"
test_str = ("012 013 019 023 024 029 034 035 039 045 046 049 056 057 059 067 068 069 078 079 089\n"
"911\n"
"900\n"
"891\n\n"
"000 010 011 987 876 765 654 543 432 321 210")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.