const regex = /((?=\b\d{3}\b)0?1?2?3?4?5?6?7?8?9?(?<=\d{3}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?=\\b\\d{3}\\b)0?1?2?3?4?5?6?7?8?9?(?<=\\d{3}))', 'gm')
const str = `012 013 019 023 024 029 034 035 039 045 046 049 056 057 059 067 068 069 078 079 089
911
900
891
000 010 011 987 876 765 654 543 432 321 210`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}