$re = '/((?=\b\d{3}\b)0?1?2?3?4?5?6?7?8?9?(?<=\d{3}))/m';
$str = '012 013 019 023 024 029 034 035 039 045 046 049 056 057 059 067 068 069 078 079 089
911
900
891
000 010 011 987 876 765 654 543 432 321 210';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);