re = /\/img\/([0-9a-fA-F]{2})([0-9a-fA-F]+)$/
str = 'example.com/img/fe5afe0482195afff9390692a6cc23e1'
subst = '/content/img/$1/$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result